Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Duplicate
    • Affects Version/s: 2.4.4
    • Fix Version/s: None
    • Component/s: Server (S)
    • Labels:
      None
    • Environment:
      CentOS 7.1 x86_64

      Description

      The zabbix_server process terminates with segmentation fault on CentOS 7.1 (it worked fine with CentOS 7.0).
      Tried with both the stock RPMs from the Zabbix repository and with a custom compiled executable.
      The error is the following:
      Program received signal SIGSEGV, Segmentation fault.
      0x00007ffff556cc00 in pthread_mutex_lock () from /lib64/libpthread.so.0
      The error is also present in dmesg:
      [ 2341.743633] zabbix_server[23652]: segfault at 18 ip 00007fbf1295dc00 sp 00007ffff5527ec8 error 4 in libpthread-2.17.so[7fbf12954000+16000]
      The error is shown with every kind of zabbix_server invocation (i.e. without arguments, with -h, with -c, etc.)

        Issue Links

          Activity

          richlv added a comment -

          could this be the same as ZBX-7790 ?

          Alessandro Baldoni added a comment -

          Yes, thank you!
          I uninstalled the trousers package and replaced it with the latest one compiled from source and everything worked fine.

          Bye
          Alessandro.

          Alessandro Baldoni added a comment -

          The problem is related to trousers and not to Zabbix.


            People

            • Assignee:
              Unassigned
              Reporter:
              Alessandro Baldoni
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: